Fluent:RibbonWindow crashes VS2008

Dec 22, 2010 at 11:37 AM

Hi,

Everytime I try to set the window to a Fluent:RibbonWindow crashes. Any ideas?

I am using VS2008 .net 3.5

Dec 29, 2010 at 12:13 AM

Can we see your code?

Jan 4, 2011 at 9:26 AM

Hi Adam,

Here is the code:

<Fluent:RibbonWindow x:Class="WpfApplication1.Window1"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:Fluent="clr-namespace:Fluent;assembly=Fluent"
    Title="Window1" Height="300" Width="300">
    <Window.Resources>

        <ResourceDictionary>
            <ResourceDictionary.MergedDictionaries>
                <!--   <ResourceDictionary Source="/RibbonControlsLibrary;component/Themes/Office2007Blue.xaml" /> -->
                <ResourceDictionary Source="pack://application:,,,/Fluent;Component/Themes/Office2010/Blue.xaml" />
            </ResourceDictionary.MergedDictionaries>
        </ResourceDictionary>
    </Window.Resources>
    <Grid>
        <Grid.RowDefinitions>
            <RowDefinition/>
            <RowDefinition Height="*"/>
        </Grid.RowDefinitions>
        <Fluent:Ribbon Grid.Row="0">
            
        </Fluent:Ribbon>
    </Grid>
</Fluent:RibbonWindow>
Code behind:
namespace WpfApplication1
{
    /// <summary>
    /// Interaction logic for Window1.xaml
    /// </summary>
    public partial class Window1 : Fluent.RibbonWindow
    {
        public Window1()
        {
            InitializeComponent();
        }
    }
}

If I edit the Window1.xaml and change the Fluent:RibbonWindow to Window then the project opens fine.
I have uploaded the sampled project here: http://cid-d40c19d81787f0af.office.live.com/self.aspx/Public/FluentRibbonWindowIssue.rar
Many thanks
Jan 5, 2011 at 12:17 AM

Hate to tell you your code ran perfectly fine on my machine. I don't see any trouble in your code. You might have something messed up in your Visual Studio.

Jan 5, 2011 at 1:51 PM

Oh crap!!!...Thanks Adam for trying it out. I am running window7, may i ask what is yours?

Jan 5, 2011 at 2:44 PM

Windows 7, But using Visual Studio 2010. Also I'm using .Net 4.0 for my applications not 3.5, but even then like I said I downloaded your example and ran it fine here. So you constructed it fine on your end. Why it's giving you an error there I don't know. I would suspect if you have a 3rd party addon running in your Visual Studio environment.