This project is read-only.

Fluent not displaying images

Jan 15, 2012 at 10:01 PM

Hi,

I just started working with this control. It is amazing =). I do have one concern, but I might be doing something wrong =).

The images for the controls on the ribbon are only visible when the application is debug mode. In design view the buttons don't display the images?!?

It is not a show stopper, but it is kinda annoying.

Any help would be greatly appreciated.

Thanks!

Mar 9, 2012 at 1:36 PM

It's some kind of limitation of Fluent.  To get around it, you can refer to all of your images like this:

pack://application:,,,/MyApp;component/Images/Save.png

Feb 21, 2013 at 12:12 AM
Hi,

I posted a discussion regarding this, so I should've searched first. But, using the Uri I still can't get the images to showup. Would you post a partial code showing how to set this up properly and/or link to documentation on how to use this?

I have a MS Ribbon project and tried to use:
                <Fluent:Button 
                    Name="buttonGreen" 
                    Header="Green"
                    Icon="/WpfExcel;compnonent/Images/LargeIcon.png"
                    LargeIcon="/WpfExcel;compnonent/Images/LargeIcon.png" />
with no success either.

My folders structure is in MVVM:
root/Images
root/Views/Shell.xaml
root/Views/ShellVM.xaml

.... tried:
                <Fluent:Button 
                    Name="buttonGreen" 
                    Header="Green"
                    Icon="pack://application:,,,/WpfExcel;compnonent/Images/LargeIcon.png"
                    LargeIcon="pack://application:,,,/WpfExcel;compnonent/Images/LargeIcon.png" />
and I get the message
"Error 1 Cannot locate resource 'wpfexcel;compnonent/images/largeicon.png'. C:\Users\eqmiller\Documents\Visual Studio 2010\Projects\WpfExcel\WpfExcel\Views\Shell.xaml 44 21 WpfExcel"

Thanks for your help!...
Feb 21, 2013 at 12:16 AM
Cancel that, I had a typo in my Uri! "comp ->N<- onent"......