The name "MetroWindow" does not exist in the namespace "clr-namespace:Fluent;assembly=Fluent'

May 23, 2014 at 3:32 PM
I run the project and everything works fine, however i cannot use the Visual Studio designer.
It just repeats the error message over and over again..
Developer
May 24, 2014 at 4:59 PM
Which Studio version are you using?
Jun 26, 2014 at 11:37 PM
I am using Visual Studio 2013.

App.xml
<Application x:Class="Admin.App"
         xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
         xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
         StartupUri="View\Main.xaml">
<Application.Resources>
    <ResourceDictionary>
        <ResourceDictionary.MergedDictionaries>
            <ResourceDictionary Source="pack://application:,,,/Fluent;Component/Themes/Generic.xaml" />
            <ResourceDictionary Source="pack://application:,,,/Fluent;Component/Themes/Metro/White.xaml" />
            <!--<ResourceDictionary Source="pack://application:,,,/Fluent;Component/Themes/Metro/MetroWindow.xaml" />-->
        </ResourceDictionary.MergedDictionaries>
    </ResourceDictionary>
</Application.Resources>
</Application>

Main.xml
<Fluent:MetroWindow x:Class="Admin.View.Main"
                 xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
                 xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
                 Title="MainWindow" Height="1080" Width="1920" WindowState="Maximized"
                 xmlns:Fluent="clr-namespace:Fluent;assembly=Fluent"
                 Style="{DynamicResource MetroWindowStyle}"
    >
<Grid x:Name="MainWindow">
    <Grid.ColumnDefinitions>
        <ColumnDefinition Width="Auto"/>
        <ColumnDefinition/>
    </Grid.ColumnDefinitions>
    <Grid.RowDefinitions>
        <RowDefinition Height="Auto"/>
        <RowDefinition/>
    </Grid.RowDefinitions>
    <ContentControl x:Name="Toolbar" Grid.Row="0" Grid.ColumnSpan="99"/>
    <GridSplitter
                Grid.Row="1"
                HorizontalAlignment="Right" Panel.ZIndex="1"
                VerticalAlignment="Stretch"
                Background="Gainsboro"
                ShowsPreview="True"
                Width="2" />
    <ContentControl x:Name="Navigation" Grid.Row="1"/>
    <ContentControl x:Name="MainView" Grid.Row="1" Grid.Column="1"/>
</Grid>
</Fluent:MetroWindow>
Reference information:
Name: Fluent
Aliase: Global
Copy Local: True
Embed Interop Types: False
FileType: Assembly
Identity: Fluent
Runtime Version v4.0.30319
Specific Version: False
Strong Name: True
Version: 2.1.0.0

This project is targeted towards .NET 4.5
Developer
Jun 29, 2014 at 5:02 PM
Have you tried it with a more recent version?
I fixed a few issues which affected design time.
Jul 1, 2014 at 3:58 AM
I downloaded from http://fluent.codeplex.com/releases Prerelease i.
Im still having the same issues.

ontop of that im also getting
Error 1 The name "Ribbon" does not exist in the namespace "clr-namespace:Fluent;assembly=Fluent". xxs\Visual Studio 2013\Projects\Shadow\Admin\View\Toolbar.xaml 10 9 Admin

when placing a ribbon in a usercontrol.

<UserControl x:Class="Admin.View.Toolbar"
         xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
         xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
         xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006" 
         xmlns:d="http://schemas.microsoft.com/expression/blend/2008" 
         xmlns:Fluent="clr-namespace:Fluent;assembly=Fluent"
         mc:Ignorable="d" 
         d:DesignHeight="300" d:DesignWidth="1920">
<Grid>
    <Fluent:Ribbon>

    </Fluent:Ribbon>
</Grid>
</UserControl>
Jul 1, 2014 at 4:08 AM
Upon loading my project i am getting this message

C:\Users\4cex\AppData\Local\Microsoft\VisualStudio\12.0\Designer\ShadowCache\bhwaimvh.xub\cph0dght.4g5\Fluent.dll
An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intended to sandbox the assembly, please enable the loadFromRemoteSources switch. See http://go.microsoft.com/fwlink/?LinkId=155569 for more information.
could you please advise why this is ?
Jul 1, 2014 at 4:19 AM
Solved.

added the following line to XDexProc.exe.config and Devenv.exe.config

<loadFromRemoteSources enabled="true"/>

Im not sure as to why its doing this. are you able to shed some light ?
Developer
Jul 1, 2014 at 3:47 PM
The released zip files don't include the most recent changes.
To get the most recent changes you have to build from source directly.
Im not sure as to why its doing this. are you able to shed some light ?
You have to unlock the zip file after downloading it from the internet. Applies to all files you download from the internet.
Marked as answer by batzen on 7/23/2014 at 2:03 PM