QAT Menu is not showing the items

Mar 5, 2010 at 8:34 AM
Edited Mar 5, 2010 at 9:37 AM

Hello,

 

I have used below code to add items in the QAT.

  <Fluent:Ribbon.QuickAccessItems>
  <Fluent:QuickAccessMenuItem Target="{Binding ElementName=mySave}" Text="Save As" IsChecked="True"></Fluent:QuickAccessMenuItem>
  <Fluent:QuickAccessMenuItem Target="{Binding ElementName=myOpen}" Text="Open picture in same Window"></Fluent:QuickAccessMenuItem>
  <Fluent:QuickAccessMenuItem Target="{Binding ElementName=myBack}" Text="Back" IsChecked="True"></Fluent:QuickAccessMenuItem>
  <Fluent:QuickAccessMenuItem Target="{Binding ElementName=myNext}" Text="Next" IsChecked="True"></Fluent:QuickAccessMenuItem>
  </Fluent:Ribbon.QuickAccessItems>

All the three elements which are marked  IsChecked true is displayed in QAT tool bar. but only in my computer i am not able to see the items in the drop down menu. But when i try the same code in other computer works fine.

Same thing happens for the code in the Samples also. (I tried in Fluent.Sample.Resizing).

Please help me to resolve this issue.

Thanks in advance,

Mohan

Coordinator
Mar 5, 2010 at 10:43 AM

Can you publish a screenshot to clarify the issue?
Fluent.Sample.Resizing sample has not Ribbon.QuickAccessItems, so menu is empty.
Daniel

Mar 5, 2010 at 11:01 AM
Hello,
You are right Resizing is not having QuickAccessItems, Actually it is
in gallery project. Here is the screenshot. You can see the quick
access toolbar has the items but in the dropdown nothing is being
listed to customize.
For your information it is working perfectly in other computer.
I am having VS2010 B2.. Even othercomputer is also having VS2010
Beta2. I am not sure why it is not working in my computer rather.
Please help me to resolve this.

Thanks,
Mohan


On Fri, Mar 5, 2010 at 4:13 PM, [email removed] wrote:
> From: daVinci
>
> Can you publish a screenshot to clarify the issue?
> Fluent.Sample.Resizing sample has not Ribbon.QuickAccessItems, so menu is
> empty.
> Daniel
>
> Read the full discussion online.
>
> To add a post to this discussion, reply to this email
> ([email removed])
>
> To start a new discussion for this project, email
> [email removed]
>
> You are receiving this email because you subscribed to this discussion on
> CodePlex. You can unsubscribe on CodePlex.com.
>
> Please note: Images and attachments will be removed from emails. Any posts
> to this discussion will also be available online at CodePlex.com



--
Thanks
Mohanraj
Coordinator
Mar 5, 2010 at 3:45 PM

Please, send me the screenshot to davinci@mail.ru or create a new issue (http://fluent.codeplex.com/WorkItem/Create.aspx) and attach the image there.
Also, what OS do you use?
Daniel

Coordinator
Mar 7, 2010 at 11:40 AM

It looks like we have compatability issues with our ContextMenu in Windows XP and Windows Server 2008.
I have created issue #16672 (http://fluent.codeplex.com/WorkItem/View.aspx?WorkItemId=16672).
Thank you, Mohan, this will be fixed soon and it will work proper in V1 for sure.