Display problem after changing Theme.

Oct 25, 2010 at 5:36 AM

I have recently added the ability to change the default them in my app using the v2.0 control. There is a display issue after changing from one theme to another, then back again or to another after that. The Fluent window image stays as the default image style for the theme you first change to. Image one shows that everything is fine changing from silver to Black the first time.

 


 

 


 

Image2 shows what the Backstage window looks like after reverting back from the Office 2010 Black Style to Office 2010 Silver. The image stays the same no matter what style you change to from then on. The biggest issue is that the lettering on the Backstage Tab becomes white and you can't see it. 

 


 

 


Coordinator
Oct 25, 2010 at 8:51 AM

Are you using 2.0 preview binaries or the latest changeset?

Daniel

Oct 25, 2010 at 1:30 PM
Edited Oct 25, 2010 at 7:00 PM

The Preview Binaries, has this been fixed in the latest changes?

 

Just tried the latest changeset and even your demo app displays this same behavior.  play with your Theme button then click the Backstage window button and see the effect.

Coordinator
Oct 27, 2010 at 10:30 AM

Thats strange, i can't repro this with the latest sources, all work just fine

Daniel

Oct 28, 2010 at 12:23 AM
daVinci wrote:

Thats strange, i can't repro this with the latest sources, all work just fine

Daniel

Sorry about that I tried downloading and compiling the latest changes again and it works as you said now. ALL BETTER!!!!!

Thank you for all your hard work and I love this control!